It's still an alarm issue

Hey guys!
I just downloaded a 1.1 141115 version firmware and uploaded to my watchX, but when the watch is in sleep mode, the alarm just doesn’t start anymore, you guy posted a message on the GitHub shows that the alarm problem is fixed, but in here it still doesn’t work.

What should I do?
Thanks
Lawrence

Hello Lawrence,

Can we make sure that you are installing the latest firmware? Can we check that you are downloading the source from the link below:

Hi mtulu, I did check twice the firmware from there, and the FW ver is still the 1.1 141115, but no matter how hard I try, the alarm only goes off when it’s not in the sleep mode

Hi Lawrence,

I will take a deep dive into problem and let you know about it:) Let me try to find the bug and post back here;)

Thanks so much :slight_smile: And I found some issue with the BMP280 library(Adafruit_BMP280_Library) when you trying to connect the BMP280 via I2C. In Adafruit_BMP280.h, it has a default I2C address (0x77) and the alternative address (0x76). Generally, the library will connect the sensor with 0x77 instead of 0x76, the caused a problem, yesterday I tried to get the data on the watch, which I found this issue :stuck_out_tongue:

If you use adafruits bmp library you can pass the i2c address within the objectname.begin() statement in setup()

Example:
bme.begin(0x76);

I am not sure if the watchX version of the library has the address already modified.

Lars

Yes, as the @venice1200 stated, it’s pre-changed at the library if you downloaded the library from our web-ste:):slight_smile:

Thank you :slight_smile:
How’s the buggy things going? I asked Zak, and he said there’s no alarm issue with the N|Watch. Recently I downloaded his firmware(Wrote using ATMEL STUDIO) and checked the pwrmgr and alarm part, it seems the same as the watchX, so it’s a little confuse for me.
By the way, I want to add a pulse sensor(HR sensor) to the watchX, if I just soldering some wire to the edge connector would it break easily? if so, what’s the part name of the female connector?

Thanks.
Lawrence

You are welcome;) I am suspecting that it’s a timer issue, still digging down though:) There are many pins available on the edge connector, you can connect a sensor that communicates with I2C. Pin out is available at user manual linked below. The edge connector we are using is impossible to find because they manufacture it based on 1500 minimum order quantity:)

If you believe in your soldering skills:) soldering wont be an issue;)

Thanks so much :wink: And another thing that I want to know about the v1.3 is how long can the watch standby(always in sleep mode, and a 130mAh battery.), mine seems only takes around 1.5 days before the ran out of the power(everything shut down even the RTC can’t count as usual).

It really depends on the firmware you flashed, display brightness and the sleep function. I normally get around 53 hours which is a little more then two full days:)

Hey there! I downloaded a newer firmware from Sasapea, and there are no alarm issues. The new firmware uses EEPROM to storage bitmaps. But it still has some problems, In the main menu, button OK and UP are reversed, and there’s also always a USB icon floating there. And the battery level is not right either, it probably for V1.2 version I think? So it’s another issue :frowning:

No it’s not for V1.2 :slight_smile: I can fix the reversed button issue, it’s easy, rest of the problems are also seems not a biggy.

Hey, Mustafa! Today I tried to debug the code and succeed! I already uploaded the code to my Github, and here’s the link of it Click here.

That’s excellent:) I will give it a go as soon as possible:)

1 Like

:wink: Thanks for your help these days.

Hey there! I found a little problem that I forgot to change the Pin layout in game2.c and timedate.c, I already fixed it in my github page. Sorry! :wink:

Thank you, informed right before claiming an issue:)

I forgot to ask one thing :wink: The BTN1 since the day I received the watch does not work well… So I’m wondering if I replace it by myself would it break the pads on the PCB?

And also I’m trying to run the arduboy on it, but the button seems not in a stable situation (not Pull Up out pullDown), where could we change in the library?