All goes well until....pfff


#1

Hi, i’m very worried because my watchx stoped and all the leds are off, and can’t connect by usb to arduino ide. if i press the reset button left led are on about 3 seconds and turns off again. Please any suggestion?

Thank you so much


#2

Have you tried this :
https://community.watchx.io/t/unable-to-upload-code-port-not-detected-solution/38

with an easy code


#3

ok, it worked!!! thank you. I am working on the tapclock program and i tried to put the temperature value, pressure in the screen. when i create the variable float type, I initialize the library. The problem appear when i try to upload the program. The watchx turns the screen black. It is using the parameter bme.readTemperature().

using this libs:

#include <Adafruit_Sensor.h>
#include <Adafruit_BMP280.h>
#include <SPI.h>

init the lib:

Adafruit_BMP280 bme;

declare vars:
float t;

in the loop:

oled.setCursor(6,4);
oled.print("T: ");
oled.print(bme.readTemperature());

any suggestion, thank you so much


#4

The latest TapClock versions using nearly all availble Memory.
Any additional code could end in an instable system if you compile and upload.
Whats the memory usage shown by the compiler?


#5

when i upload the soft indicates 93%


#6

93% is the value from where I see issues.
Which TapClock Version are you using?

Try to remove the code lines for the MAG Device (library, object, setup code) as this device is unused and only send to sleep for longer battery usage.

Where did you add your loop code?


#7

TapClock for watchX v1.2. ok i’ll try to remove the MAG device. I can’t understand the sleep mode. i can’t put the screen off, always shows the watch, so, the battery is live around 2-3 hours.

I put the bme.readTemperature in stats menu in case 110:

case 110:
// Init
init_view = true;
oled.clear();

  // Draw Header
  //oled.setCursor(44,0);
  oled.print("<Stats>");

  oled.setCursor(6,2);
  oled.print("Uptime: ");
  
  // Show MPU Angles
  if ( !mpu.getSleepEnabled() ) {
    oled.setCursor(6,3);
    oled.print("Wakes: ");
    oled.setCursor(72,3);
    oled.print("Views: ");
    // Angles
    oled.setCursor(6,5);
    oled.print("AX:    AY:    AZ:");
    //temp, humidity
    oled.setCursor(6,4);
    oled.print("T: ");
    oled.print(bme.readTemperature());
   // oled.setCursor(46,4);
    oled.print("P: ");
     //oled.print(p);
  // oled.setCursor(86,4);
   // oled.print("A: ");
     //oled.print(a);
  }

#8

State 110 is just „stats“, an status page to show a few (more) information.
No sleep here.

Sleep is in state 91 which is set from different other states.

The state which shows the clock is
61 which uses showWatchface() from an included watchface header file.

Are you using v0.8.4 or an older Version.


#9

V 0.8.4 but the question is, how activate the sleep mode in the state 91? And how deactivated? My screen is on all time.
By the other hand, maybe this evening i’ll try to do to remove MAG for try to see temperature when i press the button number 2


#10

Is the clock screen permanently shown?
An Power connection prevents the clock from sleeping.
And disable the MPU in setup.

An video will be helpful.

//Edit
I added an txt file to Github which explains the states a bit more.
See: https://github.com/venice1200/TapClock/blob/master/TapClock/TapClock_v0.8.4/TapClock_v0.8.4_States.txt