TapClock for WatchX


#21

I think it’s enough to check battery on every wake up. If the battery is below certain point, we may warn the user with led blink. As the battery level gets critically low, we may use buzzer:) What do you think?

#Edit: Such an amazing update:) I just uploaded. It’s more amazing then it’s used to be:) I had to install so many new libraries though;)

#Edit-2 I have been using the new update for last 12 hours. Here is the issues I find out so far:

  • MPU motion LED stays turned on once the watch detects a motion.
  • Right part of the Zeros cut out so they look like C

#22

Will hopefully be fixed within the next version release.

Could you show me this with an picture please.


#23

I uploaded v0.8.4 of TapClock to Github.

Some changes done

  • Battery checks => Warning & Critcal Alarm
  • Icon for showing MPU is enabled.
  • Some fixes for v0.8.2

First Post Updated


#24

This may be my fault because I uploaded the previous version and it happened to that one as well, I know it was working perfectly on the previous version. I will test and inform you again;)


#25

Ok, but I personaly got never cropped symbols.
Make sure you use an unmodified version of the ssd1306 library.


#26

Yes, that might be the case;)


#27

You can try my binary from here

https://github.com/venice1200/TapClock/releases/download/v0.8.4/TapClock_v0.8.4.hex

with the ArduBoy Loader


#28

Will try it out and post back the results:)
Thank you!


#29

Hi@all,
I found a little bug in TapClock 0.8.4.
The EEprom value for MPU Enable/Disable will be initialized with the wrong value if the sketch runs for the first time.
„EEPROM.write(4,2);“ in Setup must be changed to „EEPROM.write(4,0);“.
This sets the MPU to disabled.
I will correct it asap and upload an corrected version.
In the meantime double check the setup value for the MPU and change it to 0 (MPU disabled) or 1 (MPU enabled).
Make sure your MPU is calibrated if you enabled it.
Cheers


#30

Yeah, I see 2 as default then I switch to 1 or 0. This must be the reason, good catch!


#31

Uploaded TapClock 0.8.5 to Github
See https://github.com/venice1200/TapClock/tree/master/TapClock/TapClock_v0.8.5

Changes:

  • Moved “MPU Enabled” Position in Setup Menu to the Bottom
  • Fixed Bug in setup() „EEPROM.write(4,2);“ to „EEPROM.write(4,0);“

If you want to start from Scratch with TapClock you need to clear your EEPROM.
The IDE has some EEPROM examples.

Double check the setup value for the MPU Enabled and change it to 0 (MPU disabled) or 1 (MPU enabled).

If your MPU is not calibrated choose 0.

First Post Updated.


#32

Thank you for the update!


#33

@venice1200
It looks like you’ve removed the other watch faces. But actually, the one remaining is my favorite. :slight_smile:

And by the way, what is the meaning of the symbol next to the battery icon?


#34

Hi,
as of low Memory i have „moved“ the watchfaces into different .h files.
You have to choose only one and compile & upload the sketch.
Take a look into the ReadMe provided with the sketch.

The first Icon is the battery, the second stands for RTC Alarm Enabled and the third says MPU WakeUp Enabled.

See the ReadMe as well for the RTC Alarm Setup Values and how to switch Alarm On and Off.


#35

Hi@all,
I uploaded an actualized Version of Tapclock v0.8.5.
This version writes the default value 0 for MPU WakeUp and RTC Alarm into the EEprom.
Means both functions are disabled by default.

If you want to start from Scratch with TapClock you need to clean your EEPROM values.
The IDE has an Sketch called eeprom_clear for this.

New Binary uploaded.
See https://github.com/venice1200/TapClock/releases/tag/v0.8.5-2


#36

I am feeling an improvement on battery life with the latest update. Up time is around 50 hours and the battery is at 3.64V (%30) This could have been better because I forgot to turn off the alarm and it was ringing for around 10 minutes this morning:)

I will make a detailed test on next re-charge. What is your up time?


#37

My Times are something around 50hrs without MPU, 20-22hrs with MPU.
I think disabling the Alarm doesn’t help much.


#38

I am working on something like this, which is based on TapClock with the BlockFont.
Will be released not far away.
One requirement is an calibrated MPU!!
Maybe I can get the original MPU lib working for this.


#39

The reason why I think disabling the alarm might help is because today alarm ringed around 10 minutes. I am sure LED activity and MCU activity drawn quite a bit of the battery:D

I am really loving this watchface!


#40

Can be easily done by press and hold Button 3 (Lower Right) for around 1,2secs if the clock is shown.
This disables (temporarily) the Alarm but doesn’t modifies the EEprom value for Alarm On/Off.