Screen not working


#1

Hello, I recently worked out the issue to why no programs were working on the watch however in the process I had ran an example called OLED and was displaying patterns on the screen so I decided to press this button on the board which I assumed was the reset button however now the screen is not working. When I press the buttons they do make the sound and everything however the screen is not displaying anything. I unplugged the screen and plugged it back in however that did not fix anything and now I am extremely worried.


#2

Can anyone help? I am thinking of buying a new screen however I don’t even know if the screen is the problem.


#3

Did you check your board with the other example sketches?


#4

Well currently I am having issues because it wont let me choose the port number now so I am not really having much of a good time


#5

it doesn’t turn on anymore for anything, I even tried the old code that worked before and that doesn’t even work so perhaps it is the screen or maybe the port is messed up? However if the problem is with the actual board then would WatchX send me a new watch or would I just not be able to use it again?


#6

If you use Windows the Device Manager (and the Arduino IDE) should show an Serial Device if you connect your WatchX to an USB connector with an USB Data + Power compatible cable.
It should be shown at least for a short time after you reset it with the button behind the screen.
If this doesn’t help unplug the display and try again.
If this doens’t help unplug the battery and try again.

If you reset WatchX the left LED should flicker for a while.


#7

When I first received mine, I thought I messed it up as well. Nothing would upload. I found out that this was due to my manjaro/arch linux setup. I switched to a windows 7 machine and was able to upload to the watchx from there, but it wasn’t straight forward. What I tried is recommended in a bunch of threads on this forum already:

  • have the watch attached over usb and arduino IDE open
  • keep the reset button pressed with a pen or some flat tool
  • start the upload from your IDE
  • release the button once you see the programmer looking for an open port in the IDE (should be right after the compilation)

that will work, even if you have borked the onboard firmware somehow and the watch seems dead.

but try venice1200 suggestion first and see if the hardware still resets and responds with the led.


#8

Well the thing is I can upload things and the LEDs on the board to flicker as well as make a noise when I press the buttons due to the watchX firmware I uploaded, however the only thing that seems to not be working is the screen however I am not sure if the actual screen is broken or maybe the module on the board that connects the screen to the board is not working, when I examine the screen it doesn’t appear to look broken at all and nor does the actual connector however I am not too sure how to do a proper analysis.


#9

My OLED was no longer working after i removed it once for an button repair.
Get in contact with the ArgeX Team, maybe they can check the board for you.
Or, if you like, ask around if someone has an spare oled which lives near to you.


#10

I have a couple of spares as I ordered 4 when I smashed mine. I’m in the UK.