Issue uploading Watch Firmware


#1

Hello guys! I recently have been attempting to set up the watch which has been a success and wanted to install the firmware used in all of the example videos made by the watchX people.

Here is the video of the firmware I speak of :https://www.youtube.com/watch?v=UIgI13P5a_c

Anyway so I have found an example called “WatchX Firmware Alpha” and lead me to a website that gave me a download called “NWatch-master” so I opened the file and I saw an arduino file called “watchX” so I opened it and began to upload it to my watch, after waiting a while an error message popped up saying “An error occurred while uploading the sketch” as well as a bunch of messages in the output saying “Invalid library found in C:\Users\Zozax\Documents\Arduino\libraries\robotirremote: no headers files (.h) found in C:\Users\Zozax\Documents\Arduino\libraries\robotirremote\src”

Could someone please help me out as I really want to use this watch however am really struggling.


#2

Hello James,

First let’s make sure that you are uploading correct firmware. Did you downloaded the firmware from here: https://github.com/kghunt/NWatch

I recommend you to read through this post: NWatch firmware port to watchX

The firmware contains all necessary files inside the project folder. One more check, are you able to upload basic blink example? I want to know if any previously uploaded sketch corrupting the USB hardware inside the MCU. If you have error uploading the blink example,

I recommend you to read through this post: Unable to upload code, port not detected! SOLUTION

Let us know your progress :slight_smile:


#3

Hmm, that’s weird. I did like you said and tried to upload the blink example however it says there was an error with that. The thing is it worked before as when I finally put together the watch I uploaded the example OLED and it is currently running now. Do I have to stop it running in order to upload the watch firmware?


#4

Can someone please help me. I cant even run the basic blink code but could run the OLED when I first finished making the watch.


#5

If you uploaded a sketch, that’s fine:) Now you can try to upload the watchX code:) You don’t need to stop anything, just plug the watchX to pc, open the watchX.ino file, select the Arduino Leonardo from the boards, select port(It should say Arduino Leonardo). Then hit upload :wink:


#6

Hey, the funny thing is I worked out that the problem was that the arduino type was set to “Arduino Genuine/Uno” rather than “Arduino Leonardo” but now when I press the buttons and all they make the noise and everything however the actual screen is not working and is just black. I have tried to unplug the screen and back in however it doesn’t work. I am not sure if it is the screen or not however I really want to just get it fixed as I was dying to use this. Also the sticky square things that stuck the screen and battery to the board are no longer sticky so I have had to use tape and make it double sided to make it stick together however it stopped working before I did this. Here are pictures:




#7

Hello Zozax,

Did you tried pressing the reset button or removing the battery and inserting back again?


#8

yes I did. I am really confused to why it is acting this way